Tip: Already have a license of MailIt 4?

Support, Tips and Tricks for Proof Group's fmSpark "merge anything" utility for FileMaker Pro.
SeedCode Staff
SeedCode Staff
Posts: 2757
Joined: Thu Nov 20, 2003 11:01 am
PostPosted: Thu Aug 05, 2010 3:48 pm
If you're already using MailIt 4 or 5 and wish to use that with fmSpark (instead of MailIt 3x which comes with fmSpark) you can easily turn off the automatic plugin installation in fmSpark. Note that if you do want to use the new version of MailIt (version 5, I believe) you'll need to license it yourself (version 3 comes licensed with fmSpark).

Here's how...

1. Open fmSpark and edit the script "register email plugin".

2. Disable or delete the first PerformScript step: the one that calls "register mail.it plugin..."

3. Disable or delete the next step which sets the value of $result.

4. Add a new step setting the variable $result to 1.

5. Quit FileMaker and manually remove the MailIt 3 plugin if it is installed.

6. Manually install the new MailIt plugin if you haven't already. Registration of the plugin is up to you. If you need to register it with a script, add that script to this same ""register email plugin" script we're editing.

7. Launch fmSpark and you're good to go.

We've tested the Send Mail functionality with newer versions of MailIt and this does work, but fmSpark hasn't been fully tested with this version of the plugin so if you see anything, please let us know.
John Sindelar
SeedCode

Return to fmSpark

Who is online

Users browsing this forum: No registered users and 3 guests

cron
(855) SEEDCODE
support@seedcode.com
Follow us: