Integration problem

Support, Tips and Mods for Matt Navarre's SearchResults technique.
Posts: 25
Joined: Sat Aug 12, 2006 2:34 am
PostPosted: Mon Jul 20, 2009 3:13 am
Hi John,

Hope all is well,

I'm having a problem with the set-up of the file, I have followed all instructions and keep getting the "it looks like some of the search fields on the layout "table01 etc...Unique ID has been removed...". I even deleted all and tried again!

I have gone through the scripts and I did noticed the $$sr Objects doesn't obtain a value and neither does $$ Layout?

But my $$sr ID Field has the correct value "ProjectID-kprime"

Hope you can help,

Best regards,

Roy
SeedCode Staff
SeedCode Staff
Posts: 2756
Joined: Thu Nov 20, 2003 11:01 am
PostPosted: Mon Jul 20, 2009 6:26 am
Hi Roy,

Good to hear from you!

The literal meaning of the error is that the script can't find the search fields on your Table01 layout or you've renamed then. (More about that below)

But if $$sr Objects isn't getting a value I'd guess the script isn't going to the right layout in your file. If you didn't name your layouts Table01, Table02 etc in step 3 before you imported your scripts, you may have a problem.

If you're using Advanced, throw a break point anywhere in the "Check that search layout is correct" script and then run the search with the debugger on. If you're not on Table01 when that "Check that search layout is correct" script runs, I'd suggest deleting the layouts and scripts and starting the integration over as it will give you the cleanest result.

If you ARE on Table01 when the script runs then maybe the error is literally true.

The error you're seeing comes from one of the SearchResults scripts looking at your Table01 layout to make sure it is correct. The error is telling you that it couldn't find any searchable fields on the layout: it is looking for fields like those in the "Text fields, "Phone field", or "Date fields" sections of the layout and is showing the error because these fields either aren't on the layout any more or you've changed their object names.

To fix this I'd copy the whole Table00 Template layout and paste this on to your Table01 layout. Then repoint the ID, Display, and one of those text fields to fields in then local table.

Hope that helps.
John Sindelar
SeedCode

Return to fmSearchResults

Who is online

Users browsing this forum: No registered users and 2 guests

cron
(855) SEEDCODE
support@seedcode.com
Follow us: