Several Different Errors...

Help, Tips, and Tricks for deploying GoZync: our "sync" engine for FileMaker Go.
Posts: 142
Joined: Thu Nov 01, 2012 2:36 pm
PostPosted: Sat Jun 15, 2013 1:54 am
Hi,
I started syncing a new table 2-3 weeks ago and all appeared to be fine initially. However, I've now noticed some errors in the gzMobile sync log. The following errors appeared after creating a clone of my Mobile file and also hitting the Reset button.

00:00:00 - 00:00:17 - Asking the host for changed records: Incidents - pulling down.
00:21:21 - 00:21:38 - Retrieving the Outbox from Host
00:00:07 - 00:21:45 - ERROR:111 - We were not able to retrieve the attachments
00:00:01 - 00:21:46 - Processing 1 of 1 packages recd. (4116 records)
00:00:00 - 00:21:46 - Looking for records to delete
00:00:00 - 00:21:46 - No records present in "Incidents" - no deletion required.
00:03:42 - 00:25:28 - Processing completed

00:00:00 - 00:25:43 - Asking the host for changed records: Site - pulling down.
00:10:06 - 00:35:49 - Retrieving the Outbox from Host
00:00:25 - 00:36:14 - Processing 1 of 1 packages recd. (203 records)
00:00:00 - 00:36:14 - Looking for records to delete
00:00:00 - 00:36:14 - No records present in "Site" - no deletion required.
00:00:00 - 00:36:14 - ERROR:102 - We couldn't set this field ""
00:00:00 - 00:36:14 - ERROR:102 - We couldn't set this field ""
00:00:00 - 00:36:14 - ERROR:102 - We couldn't set this field ""
(This goes on for ever...)

We also have:
00:00:00 - 00:36:15 - ERROR:102 - We couldn't set this field "KeySeals"
00:00:00 - 00:36:15 - ERROR:102 - We couldn't set this field ""
00:00:00 - 00:36:15 - ERROR:102 - We couldn't set this field "<"

And also:
00:00:00 - 00:37:01 - ERROR:504 - We couldn't save a record

I've double checked the Integration steps and they seem fine but I can't find the 'extra' fields on the Host that are causing the 102 errors. Is it possible to search for "KeySeals" "<" and " " ?

I tried hovering over the 504 error for the tooltip as suggested at http://www.seedcode.com/pmwiki/pmwiki.p ... singErrors but that doesn't show anything at all.

Any suggestions on how to track these errors down would be really appreciated, many thanks...
Brian.
SeedCode Staff
SeedCode Staff
Posts: 691
Joined: Mon Feb 28, 2011 2:47 pm
PostPosted: Sat Jun 15, 2013 8:15 am
Hi Brian,

I can give you some details on these error code, but it looks like something in the set-up or field mapping is broken as all those 102 errors are showing "" (Null) for the field name.

111 is invalid field repetition. We use repeating fields for container management, but can't think of what would cause that off the top of my head. If it's not related to the below errors, then we'd need to take a look.

102 is field missing, which makes sense since it thinks the field names in "", seems like thats got to be a custom field mapping issue, so I would double check your set up for that table.

504 is a validation failure because a value that's required to be Unique isn't. Typically UUIDs prevent this from happening. Do you have Unique validation set on any fields that aren't UUIDs?

Other than that we'll probably need to take a peek at you files to see what's happening, so hit Jeff up at support@seedcode.com.

Thanks,
-Jason
Posts: 142
Joined: Thu Nov 01, 2012 2:36 pm
PostPosted: Sun Jun 16, 2013 10:05 am
Hi Jason,
Thanks for your input, I discovered that I had two "SyncKeySeals" layouts in the Hosted and Mobile files which were not needed, as I also had the KeySeals fields in a separate layout.

Once I had deleted those extra layouts and the relevant Integration step, the Sync log looked much healthier and the records were intact again.

One thing that does look odd:

00:00:01 - 00:00:46 - Asking the host for changed records: Police - pulling down.
00:00:00 - 00:00:46 - Retrieving the Outbox from Host
00:00:00 - 00:00:46 - Processing 1 of 1 packages recd. (0 records)
00:00:01 - 00:00:47 - Looking for records to delete
00:00:00 - 00:00:47 - Record deletion completed
00:00:00 - 00:00:47 - Processing completed

00:00:00 - 00:00:47 - Asking the host for changed records: Site - pulling down.
00:00:48 - 00:01:35 - Retrieving the Outbox from Host
00:00:00 - 00:01:35 - Processing 1 of 1 packages recd. (0 records)
00:00:00 - 00:01:35 - Looking for records to delete
00:00:00 - 00:01:35 - No records present in "Site" - no deletion required.
00:00:00 - 00:01:35 - Processing completed

Any idea why the bit in red appears?

Thanks
Brian.
SeedCode Staff
SeedCode Staff
Posts: 475
Joined: Wed Jan 02, 2013 11:47 am
PostPosted: Mon Jun 17, 2013 7:15 am
Hi Brian,

That delete step is when GoZync looks for records on the mobile device that either don't "belong" to that mobile user (according to any filters you've set up), or records that don't exist in the hosted solution because they have been deleted in the hosted solution. Looks like neither of those conditions applied in your example.

HTH

Jeff
Posts: 142
Joined: Thu Nov 01, 2012 2:36 pm
PostPosted: Mon Jun 17, 2013 10:31 am
Hi Jeff,
I understand how the delete step should work but the bit in red text is new to me. If you look at the block of text directly above it says "Record deletion completed"

Just wondered why it was different between these two TO's...

Thanks
Brian.
SeedCode Staff
SeedCode Staff
Posts: 475
Joined: Wed Jan 02, 2013 11:47 am
PostPosted: Mon Jun 17, 2013 12:56 pm
Looks like the "Site" table was empty (TotalRecordCount = 0). That's what the "No records present" red text means.
Posts: 142
Joined: Thu Nov 01, 2012 2:36 pm
PostPosted: Mon Jun 17, 2013 1:20 pm
Hmm, just ran it again and got the same result even though there were 3 updated records pulled down:

00:00:00 - 00:01:44 - Asking the host for changed records: Site - pulling down.
00:00:58 - 00:02:42 - Retrieving the Outbox from Host
00:00:02 - 00:02:44 - Processing 1 of 1 packages recd. (3 records)
00:00:00 - 00:02:44 - Looking for records to delete
00:00:00 - 00:02:44 - No records present in "Site" - no deletion required.
00:00:03 - 00:02:47 - Processing completed
SeedCode Staff
SeedCode Staff
Posts: 475
Joined: Wed Jan 02, 2013 11:47 am
PostPosted: Wed Jun 26, 2013 9:02 am
Hi Brian,

I'd be happy to help you troubleshoot a problem you're having with GoZync but I'll have to get copies of your files. You're welcome to send them to me along with a description of the problem you're seeing and how to reproduce it, and what the expected results should be.

Jeff
Posts: 142
Joined: Thu Nov 01, 2012 2:36 pm
PostPosted: Wed Jun 26, 2013 12:02 pm
Hi Jeff,
Thanks for the offer but it seems to have worked itself out somehow...

Return to GoZync

Who is online

Users browsing this forum: No registered users and 1 guest

cron
(855) SEEDCODE
support@seedcode.com
Follow us: