New, changed and deleted Records are not synced

Help, Tips, and Tricks for deploying GoZync: our "sync" engine for FileMaker Go.
Posts: 21
Joined: Fri Nov 02, 2012 12:09 am
PostPosted: Mon Apr 04, 2016 11:54 pm
Hello,

new, changed and deleted records in my mobile file are not synced with the hosted side. The initial sync with 169 new records worked fine. Any changes afterwards are not pushed to the hosted file. Default Sync is round trip. We use GoZync 5.06. Main priority is that changes and new records are synced, it is not absolute necessary that deleted records in the mobile file are deleted on hosted side too. How can i set up this?

Many thanks,

Torsten

Edit: Even Default Sync: Push is not working. Records GZ_send is = 1, GZ_sent is = 0. Zync Log says that everything is ok; found 4 records to push - Push complete. But the found records are not in the hosted file.
SeedCode Staff
SeedCode Staff
Posts: 189
Joined: Tue Sep 22, 2015 2:27 pm
PostPosted: Tue Apr 05, 2016 10:54 am
Hi Torsten,

Thanks so much for reaching out to us here. Since new records are not being synced to your hosted file, I would wonder if the "Allow creation of records in this table..." option is enabled in your gzh_ relationships in GoZyncMobile. However, it sounds like edits to existing records are not being pushed to your hosted file either. Since this is the case, I'm going to email you directly for additional troubleshooting on this.

Regarding deletes, records that are deleted in your mobile file are not deleted in your hosted file. If you'd like to make that happen, we have some more info and instructions at this link: http://www.seedcode.com/pmwiki/index.ph ... c5.Deletes

Thanks again,
Posts: 21
Joined: Fri Nov 02, 2012 12:09 am
PostPosted: Tue Apr 05, 2016 10:47 pm
Hi Dan,

thank you for your reply! The "Allow creation of records in this table..." option is enabled in my gzh_ relationships in GoZyncMobile, i have checked that. The first sync worked fine, 169 Records were created in my hosted file.

Yesterday i made some additional tests and edits to existing records where correctly pushed to my hosted file. Maybe i have made a mistake during initial testing. So everything is fine with that!

The only problem which remains is pushing new records to my hosted file after the first sync.

Thanks in advance,

Torsten
SeedCode Staff
SeedCode Staff
Posts: 189
Joined: Tue Sep 22, 2015 2:27 pm
PostPosted: Wed Apr 06, 2016 10:47 am
Hi Torsten,

Thanks for the update! I've replied to your email requesting a copy of your files, so we can take a closer look. I expect we can find the solution for you once we get a chance to dig into the issue.

Thanks again,

Return to GoZync

Who is online

Users browsing this forum: No registered users and 1 guest

cron
(855) SEEDCODE
support@seedcode.com
Follow us: