Pulling Records Step not Adding to Mobile Side

Help, Tips, and Tricks for deploying GoZync: our "sync" engine for FileMaker Go.
Posts: 3
Joined: Fri May 20, 2016 12:13 pm
PostPosted: Fri May 20, 2016 1:31 pm
I am on GoZync 5.06 and I'm trying to pull data from my server to my mobile file. When I pull, it goes through the motions of pulling 13,000 records, but only 1875 records are in my table. My logs say that the pull completed and that 13,000 records were pulled, but I'm not seeing them.

I've tried resetting my GoZyncMobile file, saving as a clone and trying again, and I've checked the configurations and have these setup properly (I even have the boxes "Allow creation of records..." checked). I've also checked my scripts to make sure they are configured properly and they are. My gz_id field in my database is set to the proper "List Of" field. I don't have Custom Field Mapping, or any Parent/Child Relationships setup. I also don't have any special "Filter Records to Pull" setup.

Anyone have a thought on what could be causing me not to see those 13,000 records? Or does anyone have anything else that I could check? I have many tables syncing, but there is only one table that is giving me this trouble.

Thanks!
Ben Kingsbury
SeedCode Staff
SeedCode Staff
Posts: 2757
Joined: Thu Nov 20, 2003 11:01 am
PostPosted: Fri May 20, 2016 2:08 pm
Hi Ben,
Would you happen to be pulling more than one table occurrence based on the same table as these 13,000 records? For example, are the 13,000 records the children of Projects (for example) AND the children of Contacts (as a notes table might be)?

If so, you may try turning off deletes to see if that changes things. Ping me back in either case and we can see if leaving deletes off is right for you, why that was happening, or dig deeper if that's not the issue.

Info on how to turn off deletes is at the bottom of the page here: http://www.seedcode.com/pmwiki/index.ph ... c5.Deletes

- John
John Sindelar
SeedCode
Posts: 3
Joined: Fri May 20, 2016 12:13 pm
PostPosted: Mon May 23, 2016 11:00 am
Hi John,

No this table is not the child of two tables. Our parent table is called PlotPlanting and PlotOrder is the child. The PlotOrder table is the one I'm having trouble with. I have both of these tables syncing separately instead of doing the related syncing.

I tried turning off deletes, but its the same thing. It goes through the motions of pulling, but they never get added. Any other thoughts?

Thank you,
Ben Kingsbury
SeedCode Staff
SeedCode Staff
Posts: 189
Joined: Tue Sep 22, 2015 2:27 pm
PostPosted: Mon May 23, 2016 12:42 pm
Hi Ben,

Thanks for checking that out. I have one other hopeful thought for you. In GoZyncMobile, double check that your gzm_PlotOrder table occurrence is pointing at your PlotOrder table in your *mobile* file. I'm curious if it might be pointing at your hosted file instead.

If that isn't the problem, please email us at support@seedcode.com, and we'll continue troubleshooting from there.

Thank you!
Posts: 3
Joined: Fri May 20, 2016 12:13 pm
PostPosted: Mon May 23, 2016 12:57 pm
Thanks Dan,

I did double check that and it is pointing to the correct file. I will send you the link to these forms.

Thank you all for your help so far! I'm sure I'm missing something simple.
Ben Kingsbury
SeedCode Staff
SeedCode Staff
Posts: 189
Joined: Tue Sep 22, 2015 2:27 pm
PostPosted: Mon May 23, 2016 3:04 pm
Hi Ben,

Thanks for letting me know. Thanks also for sending us a copy of your files. I will follow up to your email there shortly.

Return to GoZync

Who is online

Users browsing this forum: MSN [Bot] and 2 guests

cron
(855) SEEDCODE
support@seedcode.com
Follow us: