Page 1 of 1

'Uploading Applications' broken...but not always! **Answered

PostPosted: Tue Mar 13, 2018 2:10 pm
by Frostie
Hi all,

I'm trying to upload a new version of the mobile file to the server. I run the script 'Zync - Prep and Upload New File' from the mobile file. The file is transferred to the temp directory on the local machine without a problem.

From GZM, I then select 'yes' to include a new version of GZM, then click on Upload.

I'm seeing the following error
Capture.PNG
Capture.PNG (15.37 KiB) Viewed 7292 times


If I log into GZM first as user admin, I don't get the error.
Rebooting the PC has not fixed the issue.

This process has been running smoothly :D I appreciate that this may not be a Go Zync issue, but I just can't think what has changed to cause the problem! Does anyone have any suggestions??

Re: 'Uploading Applications' broken...but not always!

PostPosted: Wed Mar 14, 2018 7:56 am
by kcembrey
Hi Frostie,

Sorry to hear you're running into this issue. The first thing to check would be to make sure you're logging in to your mobile file with an account that has full-access privilege to GoZyncMobile (such as admin).

Let me know if that helps and I'll reach out to Todd to see if he has any suggestions on what else could be causing this issue.

Regards,

KC

Re: 'Uploading Applications' broken...but not always!

PostPosted: Wed Mar 14, 2018 3:19 pm
by kcembrey
Hi Frostie,

The info I heard back from Todd is that it looks like GZM can't be exported to the temp directory. I don't know why that would be. You'll want to run that with script debugger and check the export path to see if there's an issue saving to that directory. One thing you could try first is running it from another machine to rule out any issues on the specific machine you're working with.

Let me know if that helps.

Regards,

KC

Re: 'Uploading Applications' broken...but not always!

PostPosted: Thu Mar 15, 2018 4:46 pm
by Frostie
Hi KC,

Thanks for your reply.

I've run this process using the debugger.

If I start from the beginning, open the mobile file (using an account with admin rights) and run 'Zync - Prep and upload....' and then from GZM
click on the 'Upload' button, the debugger reports that Get(AccountName) = Sync, and the script fails to save a compacted copy to $GZMPath.

If I re-login to GZM as Admin first, the process runs without error.

Should GZM be using the Admin or Sync account? How is this controlled??

Thanks again,

Frostie.

Re: 'Uploading Applications' broken...but not always!

PostPosted: Fri Mar 16, 2018 10:21 am
by kcembrey
Thanks for the details, Frostie.

You'll need to log-in as the Admin user in order to export the file to a temporary directory to be uploaded to the GoZyncHosted file as the Sync user won't have permission to export the file. This is why you're seeing the error when it tries.

The Sync user is set-up to be able to synchronize data between your mobile and hosted files, but it's not set up to be able to upload new copies of your mobile file, as you may want to prevent any user from being able to run that script and replace the files available to everyone.

Regards,
KC

Re: 'Uploading Applications' broken...but not always!

PostPosted: Mon Mar 19, 2018 4:18 pm
by Frostie
Why didn't I notice that before? :oops: Doh!

Thanks KC :)

Re: 'Uploading Applications' broken...but not always! **Answ

PostPosted: Mon Mar 19, 2018 4:23 pm
by kcembrey
Absolutely, Frostie!

Glad that helped.

Regards,

KC