Updating To DayBack 10.22

Notes on our latest calendar for FileMaker 13,: DayBack
SeedCode Staff
SeedCode Staff
Posts: 96
Joined: Mon Aug 13, 2012 7:43 am
PostPosted: Thu Jan 25, 2018 4:07 pm
Please back up your file before making any changes.

If you haven't already, navigate to the "Settings" tab in the calendar sidebar and click "Account Settings". Click "Check For Updates". This button should change to "Install Update" and inform you that version 10.22 is available. Click "Install Update".

To update the necessary scripts, begin by downloading the latest version of DayBack here:

You should follow these instructions if you have done the embedded integration or the linking integration and you don't want to perform the integration all over again.

The Changes

Update the following scripts in your current DayBack File (Your file if you have done an embedded integration), but don't delete the script itself. Rather, just replace or add the script steps highlighted in the images below from the new version of DayBack into the corresponding script in your DayBack file. You may get an error when opening both files at the same time. This is expected and you can just say "OK" to those errors before continuing. Here are the scripts and script steps that needs to be updated this way:

"WebViewer Settings" REPLACE the script step "$sc_OptionsResult"

Screen Shot 2018-01-19 at 10.31.45 AM.png
Screen Shot 2018-01-19 at 10.31.45 AM.png (208.1 KiB) Viewed 1998 times


"Load Calendar Settings - On Startup" ADD the script step "$sc_ShowRemoteNotifications"

Screen Shot 2018-01-19 at 10.32.07 AM.png
Screen Shot 2018-01-19 at 10.32.07 AM.png (131.13 KiB) Viewed 1998 times


"Get Webviewer Calendar FilePath"
Delete the "Set Variable [ $$sc_Webviewer_URL..." script step from line 31 of your copy of the script, then copy the highlighted lines below from the new version of DayBack to corresponding file in yours.

GetWebviewerCalendarFilepath.png
Get Webviewer Calendar FilePath
GetWebviewerCalendarFilepath.png (581.9 KiB) Viewed 81 times


Finishing Up:
Close the new DayBack file you used to copy the script contents from.
Change the build number recorded in the database. Navigate to "File -> Manage -> Database" then go to the "CalendarInterface" table. Change the "BuildNumberCalc" calculation to read "10.22". Click "OK" to save those changes.

Then please run the "Upon Opening" script in your file. This will ensure all of the new settings load properly and the calendar loads with the correct data.

That's it, enjoy DayBack 10.22.
Posts: 9
Joined: Tue Nov 22, 2016 8:22 pm
PostPosted: Sat Jan 27, 2018 11:51 am
I am working on a file that was not using the in-app updates, and has to be manually updated, starting with 9.90. I've gotten as far as 10.00, but cannot get the version number to change if I display the Account Settings, even after a full re-start. It still says 9.90. Does that string look anywhere other than CalendarInterface::BuildNumberCalc? Is it running some kind of validation, meaning I've made an error updating the script steps?
SeedCode Staff
SeedCode Staff
Posts: 297
Joined: Tue Nov 08, 2016 1:54 pm
PostPosted: Mon Jan 29, 2018 11:26 am
Hi Datagrace,

The build number is updated when you run the in-app updates in the calendar. The FileMaker script updates work in conjunction with the in-app updates to integrate new features and bug-fixes into the calendar. In-app updates are required to install these features to the core calendar code.

Your purchase of DayBack includes 1 year of in-app updates. If your in-app updates have expired, you can purchase an additional year at our page here: https://www.seedcode.com/extend-in-app-updates/

Hope that helps! Let us know if you have any further questions.

Regards,

KC
Posts: 9
Joined: Tue Nov 22, 2016 8:22 pm
PostPosted: Mon Jan 29, 2018 12:37 pm
After making the manual changes and clicking on the 'Check for Updates' button, I get an error message 'There are a few Filemaker changes required between 9.90 and 10.23...' The green Install Update button is still visible, and clicking it displays a Filemaker message window ('Update Calendar') with a message that 'Updating the calendar make take a moment...', but, so far as I can tell, nothing happens after clicking 'Update' and the build number remains at 9:90.
SeedCode Staff
SeedCode Staff
Posts: 297
Joined: Tue Nov 08, 2016 1:54 pm
PostPosted: Mon Jan 29, 2018 12:57 pm
Hi John,

If you've recently upgraded to FileMaker 16, you'll need to make sure you follow the "FileMaker 16: Changes Required" section of the docs here to enable the fmurlscript extended privilege for your user: https://www.seedcode.com/pmwiki/index.p ... ker.FMPURL

Also, check that you are able to see the DayBack logo at this page from the computer you're using for the update: http://dayback.io

If you've checked both those things and are still unable to apply the update, you can send over a copy of your DayBack file to us at support@seedcode.com so we can troubleshoot on our end.

Thanks,

KC
Posts: 9
Joined: Tue Nov 22, 2016 8:22 pm
PostPosted: Tue Jan 30, 2018 4:02 pm
I've checked both those things; no joy. Emailing the compressed file. Please let me know if not received (30 meg).
Posts: 9
Joined: Tue Nov 22, 2016 8:22 pm
PostPosted: Sat Feb 03, 2018 7:47 pm
Help received, and I was able to bring the file up to date. Thank you.
SeedCode Staff
SeedCode Staff
Posts: 297
Joined: Tue Nov 08, 2016 1:54 pm
PostPosted: Mon Feb 05, 2018 10:12 am
Hi John,

Thanks for verifying you're up and running in the forum. Glad we were able to find the broken references in a couple scripts and get your DayBack up to date!

Regards,

KC

Return to DayBack Calendar for FileMaker

Who is online

Users browsing this forum: MSN [Bot] and 2 guests

cron
(855) SEEDCODE
support@seedcode.com
Follow us: