Page 1 of 1

FMP URL protocol message

PostPosted: Wed Jun 27, 2018 9:39 am
by wsmiii
Hello -

Upon starting my modified DayBack I sometimes see the message, "It appears that the FMP URL protocol is not working...(etc.)."

However, once I've dismissed the message DayBack most often works fine. Very occasionally it initially displays no events, but simply refreshing it results in normal functioning.

- I believe this started happening AFTER a recent DayBack update (a month ago?) designed to improve detection of FMP URL functioning.

- The message is more likely to appear when my internet connection is bogged down/things are running more slowly, including starting DayBack.

- It is also more likely to occur when I open my solution using FMP 15 Advanced rather than FMP 16. (These are installed on different partitions so they don't confuse URL access). Most often I don't see the message upon opening my solution with FMP 16. (FMP 16 has always started DayBack more quickly than FMP 15 when accessed from a remote location, especially repeated startups. I think 16 does more caching.)

- I've taken all the steps previously posted here vis testing and setting up FMP URL access.

- My solution is hosted remotely by Datatrium. I develop using MacOS Sierra and High Sierra, but IIRC I see the message under Windows 10 too.

Again, particularly with FMP 16, I often don't encounter the message at all.

Any thoughts?

Re: FMP URL protocol message

PostPosted: Wed Jun 27, 2018 10:00 am
by kcembrey
Hi wsmiii,

I think you're correct that the recent changes to the FMP URL check are what is causing you to see the notice.

In the "Check for FMP URL" script, we give the calendar 5 seconds to load and run a check, then the "Check for FMP URL" script verifies that it was successful. What's likely happening is that things haven't finished in time before the "Check for FMP URL" script is run.

You can adjust the time allotted for this check by changing the Interval value on line 25 of the "Check for FMP URL" script to something larger than 5. Maybe try 10-seconds. It won't affect the loading speed of the calendar, but just delay the check to give the loading scripts more time to finish.

Let me know if that helps!



Re: FMP URL protocol message

PostPosted: Wed Aug 01, 2018 9:49 am
by Jim2001
I've got a similar issue but with FM Go. When I start the calendar the message comes up the FMP URL isn't working. I dismiss the message and it runs fine. My client does it and when he dismisses the message there are no events. I set the interval to 10 just to see if that made a difference, and it did on my iPad but not on my clients ipad. Very puzzling.

Another behaviour I noticed is that if I start the calendar directly then all is well for me, but if another file calls the calendar then the error message is back again.

I am running the most current versions of 16 in all cases and the most recent dayback version.

Re: FMP URL protocol message

PostPosted: Wed Aug 01, 2018 12:19 pm
by kcembrey
Hi Jim,

Thanks for the details. On your client's device, are they logging in with the same user? Have you verified that the user account is assigned with a security privilege that has the fmurlscript extended privilege assigned?

Since we're unable to replicate this issue in a stock copy of DayBack, would it be possible to have you send over a copy of the files (clone would be fine) to so we can troubleshoot it on our end?



Re: FMP URL protocol message

PostPosted: Sun Aug 12, 2018 6:37 am
by jimrecht

I'm having the same problem that the original post describes. I edited the specified script per KC's instructions. I've tried 10 and 15 seconds. It doesn't help. The problem persists. I get the same error message. Please advise.

Re: FMP URL protocol message

PostPosted: Sun Aug 12, 2018 2:38 pm
by John Sindelar
Hi Jim, it's likely not the timing issue, which is quite old, but rather changes in FM 16 and 17. You'll find a description of the changes and troubleshooting steps here: ... ker.FMPURL

That should get you going again =)

- John

Re: FMP URL protocol message

PostPosted: Tue Aug 14, 2018 11:39 am
by jimrecht
Thanks John. Problem solved once I completed all of the steps in your instructions. Thanks!
Now I've encountered a new problem -- something I must have broken during this last update.
I will post separately.

Re: FMP URL protocol message

PostPosted: Wed May 18, 2022 7:41 pm
by dzakary
I've just finished updating an embedded Dayback to 10.60. I had to update from a few versions back. Client is running latest Server 19 and client 19. We're still getting the fmp url error message. Not quite sure where to start looking. Was pretty meticulous on copying and modifying scripts.

Any suggestions where to look first?