Page 1 of 1

Tooltips stop working

PostPosted: Tue Dec 18, 2018 7:03 am
by jffortier
I don't know where I lost it in my implementation (started with 10.41), but the tooltips is not working.
I don't even see the hand on event hover. I updated my application to 10.45.

I tested on a fresh 10.42 (source 1) and it's working, I setup the script load source as per example and the tooltips work as expected. I then open the 10.44 file, updated to 10.45 and copy the script line from 10.42 into 10.45... and the tooltips is not working, but I see the hand on event hover, but nothing shows up.

I downloaded a fresh copy of 10.45 and it's working :cry: :?:

I emptied the user\local\temp folder, restart, same results.

Where did I go wrong ?? Since this is done in a world I know nothing about, I can't trouble shoot with the debugger !


Re: Tooltips stop working

PostPosted: Tue Dec 18, 2018 7:52 am
by John Sindelar
This can be frustrating to work with since FileMaker can't tell us if the JS is right or not. And, as you say, there's no script debugger. It's a lot of trial and error. But it's also kind of fun... at least once it starts working. =)

If I'm reading your post correctly, it sounds like you can paste your JS tooltip into a new download of 10.45 and it works correctly, but if you add the same line to your file which has been updated to 10.45, it doesn't work. Do I have that right?

If so, two things to try:

1. There was a FileMaker script change required in 10.44 that you may have missed. I'd revisit the instructions for that update here and confirm that you made all the correct changes: ... ionHistory

2. If your JS has commas in the code, try testing with one that doesn't: see if a simpler tooltip like "javascript:dbk.tooltip(event.title);" works in one and not the other.

Let us know what you find,

- John

Re: Tooltips stop working

PostPosted: Tue Dec 18, 2018 7:50 pm
by jffortier
Thanks John,

I retrace the modifications since 10.42, everything was done as indicated.

I tried to disable the script line and copy the original from 10.45, same result.

on the 10.45 with or without coma it work, on mine, no change.

I also tried to replaced both web-calendar.js/css just in case... still not working.

As I mentionned, the cursor hand is not showing in the web viewer... It work at some point because when I configure it the 1st time it work.

Any other ideas ?

Re: Tooltips stop working

PostPosted: Wed Dec 19, 2018 7:24 am
by John Sindelar
Thanks for the details!

Copying and pasting from a working copy to yours should definitely work if all the intervening updates were made. Normally I'd suggest you might be pasting in some stray characters, but that would probably raise an error in DayDack instead of just doing nothing. We should probably take a look at your file. I'll email some next steps.

Re: Tooltips stop working

PostPosted: Wed Dec 19, 2018 1:08 pm
by ana
Hi Jean-Francois,

Thank you for sending over the file. We just need to add the Event Actions to your "Load Source Settings at Startup --- Describe Your Sources Here ---" script. We have some documentation here: ... entActions

Please see the below screenshot for an example of the changes you need to make. You make these changes on line #39 and line #84.

Screen Shot 2018-12-19 at 13.06.12.png
Screen Shot 2018-12-19 at 13.06.12.png (234.35 KiB) Viewed 1210 times

Let us know if that helps.

Best wishes,

Re: Tooltips stop working

PostPosted: Wed Dec 19, 2018 4:43 pm
by jffortier
Boy I feel so stupid !!

I typed exactly like the picture in the link you gave me... the only thing I didn't get was the last line of code

"[editable]" ... my calendar is readonly that is why it was not showing up... it was editable then I switch it back to readonly because of the status conflic that I need to fix when I was moving an event in the calendar... that is why it was working before and it stop working after !!

The only thing now is why the little hand is not showing up ??

In Horizon view it is on the text, not the color rectangle to le left. But it shows in between rectangle's lines.
Day/week/month view... no hand icon.

Thanks again for your help

Re: Tooltips stop working

PostPosted: Thu Dec 20, 2018 1:23 pm
by ana
Thank you for letting us know Jean-Francois. We are seeing the same behavior for Read-Only events on the calendar. I'll check on this and let you know.

Re: Tooltips stop working

PostPosted: Thu Dec 20, 2018 1:26 pm
by ana
And you shouldn't feel stupid. We look at this code every day and make similar errors all the time!!!

Re: Tooltips stop working

PostPosted: Fri Dec 21, 2018 6:44 am
by JasonYoung
Hi Jean-Francois,

It turns out this cursor behavior is unrelated to the new Hover event and is a small bug having to do with Read-Only calendars, so thank you for bringing this to our attention.

I believe the original intention was to hide the pointer cursor (the hand) on read-only calendars to indicate that the events were not draggable, and the cursor showing on the text in horizon view was unintentional. I've made a case to make this behavior consistent and since the events are clickable in Read-Only, I think the appropriate behavior is to always show the pointer/hand, even for read-only calendars.

This will be addressed in an upcoming version, so stay tuned for that.

Thanks Again!