Looping FMP URL Failed

Notes on our latest calendar for FileMaker 13,: DayBack
Posts: 65
Joined: Fri Jul 17, 2009 7:44 am
PostPosted: Tue Jan 07, 2020 6:52 am
I'm not sure what I did but now when I start up DayBack the FMP URL Failed message comes up constantly. If I click OK it waits a few seconds and then comes up again. It does allow me to close the file and reopen it from a script I have in another file. Then all is well. It's just the first time it's started that is causing this issue.

I am running FMA18 with DayBack 10.55 under High Sierra. Also be aware that I have many previous versions of Filemaker on this machine since.
SeedCode Staff
SeedCode Staff
Posts: 7
Joined: Wed Oct 09, 2019 7:39 am
PostPosted: Tue Jan 07, 2020 8:29 am
Hi Jim,

If I understand correctly, the FMPurl error does not occur when you open DayBack from your other file and the calendar opens with events loaded- it is only when you launch DayBack directly that the FMPurl protocol fails, and no events load? I wonder if the FMPurl check script tries to run before the calendar finishes loading when you launch DayBack on its own. One thing to try would be to open the "Check for FMP URL" script, and increase the timer interval for the Install OnTimer Script step on line 25. By default it is set to 5 seconds, but you could increase that to 7-10 and see if you still get the error when launching the app directly.

Please let me know if that helps.

Regards,

Becca
Posts: 65
Joined: Fri Jul 17, 2009 7:44 am
PostPosted: Tue Jan 07, 2020 10:38 am
Yes, no events load. I set the timer to 10 and it seemed to work. I also changed the my own startup script in the other file so that the calendar is the last file to load (instead of the second last). Also there is another Install OnTimer Script event at line 13 in that same script. I think it's currently set to 1.
SeedCode Staff
SeedCode Staff
Posts: 7
Joined: Wed Oct 09, 2019 7:39 am
PostPosted: Tue Jan 07, 2020 11:58 am
Hi Jim,

The Install OnTimer Script step on line 13 of the "Check for FMP URL" script should be set to 0. This way it will cancel out the OnTimer script that is set previously so it doesn't continue to run and chew up your system's resources.

Is there anything else I can help you with?

Regards,

Becca
Posts: 65
Joined: Fri Jul 17, 2009 7:44 am
PostPosted: Tue Jan 07, 2020 12:14 pm
I think setting line 25 to 10 and moving the startup order in my file did the trick. Thanks.
SeedCode Staff
SeedCode Staff
Posts: 7
Joined: Wed Oct 09, 2019 7:39 am
PostPosted: Tue Jan 07, 2020 12:44 pm
Hi Jim,

Glad to hear we were able to get it working. Have a great rest of your day!

Regards,

Becca

Return to DayBack Calendar for FileMaker

Who is online

Users browsing this forum: No registered users and 2 guests

(855) SEEDCODE
support@seedcode.com
Follow us: