Subscribe: All Events showing today rather than actual

General Information about upcoming products, upgrades, etc.
Posts: 49
Joined: Tue Apr 14, 2015 7:06 am
PostPosted: Mon Nov 09, 2015 9:40 am
Ok, this must be a really simple mistake I have made somewhere.

First attempt to implement Subscribe and all seems very simple, except the dates/times of the events appear to be the timestamp the url is subscribed to rather than the dates in the vent records.

A setup test shows things apparently correct, I can see the timestamps in the VCalendar to be as expected ( e.g. DTSTART:TZID=Europe/London:20150909T110000 ) - see attached, but in Google all 7 events have a start and time of 5.15p today, and iCal has them at 17.17 - actually correct that - iCal now has them as 17.30 - I guess when it refreshed!

I am using essentially the SampleEvents table from DayBack with duplication of the timestamp calc fields without the GetasNumber and set to be timestamps not numbers for the timestamp fields

What have I missed or done wrong?
(Quite happy to send you the url if it would help)

Thanks

Tim
Attachments
SetupTest.png
Setup tst result
SetupTest.png (136.99 KiB) Viewed 4191 times
Posts: 49
Joined: Tue Apr 14, 2015 7:06 am
PostPosted: Mon Nov 09, 2015 2:53 pm
I should add FMS14.0v3 on OSX 10.10.5
SeedCode Staff
SeedCode Staff
Posts: 189
Joined: Tue Sep 22, 2015 2:27 pm
PostPosted: Mon Nov 09, 2015 4:08 pm
Hi Tim,

Thanks so much for reaching out. This is a peculiar error indeed!

I don't immediately have the answer for you. But yes, if you don't mind, would you send us the calendar URL so we can take a look? You can email it to us at support@seedcode.com, if you'd rather not paste it in the forum here.

Thank you!

Dan

Dan Wheelon
support@seedcode.com
tel. (855) 733-3263
http://www.seedcode.com
Posts: 49
Joined: Tue Apr 14, 2015 7:06 am
PostPosted: Tue Nov 10, 2015 5:33 pm
Update for All,

I sent Dan the URL, and it worked perfectly for him.
24 hours after my initial post my Google calendar had updated itself and was showing correct dates and times. The iCal one was not though, all entries were moving as one to the last refresh date/time.
I deleted the iCal calendar and created a new one with no changes to my setup file and it is now behaving as it should.
No idea what was wrong, but clearly nothing to do with Subscribe - maybe a glitch with iCal?

Thanks to Dan for his help
SeedCode Staff
SeedCode Staff
Posts: 189
Joined: Tue Sep 22, 2015 2:27 pm
PostPosted: Wed Nov 11, 2015 9:26 am
Tim,

Thank you for the update! Glad your subscription is working as expected now.

All the best,
Dan

Return to FileMaker Products (General)

Who is online

Users browsing this forum: No registered users and 1 guest

cron
(855) SEEDCODE
support@seedcode.com
Follow us: