Dayback Online problems

Notes on our latest calendar for FileMaker 13,: DayBack
Posts: 66
Joined: Wed Nov 27, 2013 5:51 am
PostPosted: Sun Jan 13, 2019 7:33 am
Hello -

I’m having difficulty setting up DayBack online. I get a 959 error upon attempting to interact with the calendar via browser, and “Test Source Setting” tells me that my main FileMaker Pro file isn’t available.

I have an activated account.

I have a source set up and pointed at my dedicated FMP17 server (hosted by Datatrium). My renamed php relay file is properly placed and specifies one hard-coded FileMaker Pro user name and password. PHP is active.

To simplify troubleshooting I uploaded a new, virgin copy of Dayback to my server with one password protected account (same as specified by my relay file). It works remotely under FMP17 Advanced without problems (once needed extensions were activated).

My Dayback Online Administrative Source settings are pointed at this virgin “Dayback.fmp12” as my FileMaker file name.

My source settings are:

Server address is [my dedicated Datatrium server name].com
Server protocol is https
Server port is 443
PHP relay file name is MyRelay.php
FileMaker file name for testing purposes is Dayback.fmp12. That file is located in the “databases” folder of my server and works remotely under FMP17.
Source layout name is Source No 1 (although I doubt that “Test Source Settings” gets that far).
Read Only is “No” (the error persists with “Yes” selected).

Upon running “Test Source Settings” I get:

- Passed: the PHP Relay file is available.

- Failed: the file “DayBack.fmp12” is not available.

I get the same result using my actual, live FileMaker Pro Dayback file, or even when pointing the source at the demo file on my server. So the problem doesn’t appear to be with my file.

So, what is blocking access?

Thanks!
SeedCode Staff
SeedCode Staff
Posts: 295
Joined: Tue Nov 08, 2016 1:54 pm
PostPosted: Sun Jan 13, 2019 9:19 pm
Hi wsmiii,

It seems like the FileMaker error 959 is being returned from FileMaker when the PHP relay file is trying to get a list of the databases. This can happen if a FileMaker service was not setup right or has crashed. Here are a couple things to try:

Make sure you've fully enabled Custom Web Publishing with PHP as detailed here (many people miss the part about using the Command Line Interface to enable all the features in step 2): https://fmhelp.filemaker.com/help/17/fm ... -phps.html

Try restarting the FileMaker Server completely to see if there is an issue with one of the services. Sometimes just restarting the services works, but a few users have run into these issues until the perform a full restart of the computer.

Let me know if that helps!

Regards,

KC
Posts: 66
Joined: Wed Nov 27, 2013 5:51 am
PostPosted: Mon Jan 14, 2019 9:16 am
OK - When I get the CLI intervention and the reboot to happen (through the host) I'll check back. Thank you!
SeedCode Staff
SeedCode Staff
Posts: 295
Joined: Tue Nov 08, 2016 1:54 pm
PostPosted: Mon Jan 14, 2019 9:58 am
Sounds good, wsmiii.

If you're still running into the same error after that, you can reach out to us here or at support@seedcode.com and we'll set up a screen-share so we can take a quick look together.

Regards,

KC

Return to DayBack Calendar for FileMaker

Who is online

Users browsing this forum: MSN [Bot] and 2 guests

cron
(855) SEEDCODE
support@seedcode.com
Follow us: